Revs and revs till stalls, what could it be?

Post Reply
Benp124
Junior Member
Posts: 5
Joined: Tue Feb 05, 2019 5:30 am

Revs and revs till stalls, what could it be?

Post by Benp124 » Tue Feb 05, 2019 5:35 am

I have a Subaru brat or brumby as it’s known in AU, I have the uk model (and I am from the uk) and have recently got the car running, I’ve fitted an alternator to the engine and this is all the work I’ve done, when the car starts, it will idle, and then when I touch the throttle and sometimes even if I don’t, the car redlines aggressively until it stalls, what could this possibly be? Another issue I’m having is that the car won’t shift into FWD? Any suggestions on either of these problems would be greatly appreciated!

User avatar
El_Freddo
Junior Member
Posts: 11867
Joined: Tue Oct 04, 2005 10:00 am
Location: Benders (aka Bendigo) Vic

Re: Revs and revs till stalls, what could it be?

Post by El_Freddo » Tue Feb 05, 2019 7:30 pm

G’day Benp,

The 2wd issue could be that the 4wd has the front and rear axles fighting each other. Also known as binding. Jack up a wheel and it’ll probably spin once enough weight is off the tyre. After this you should be able to drop it back into 2wd.

As for the revving issue - are both throttles in the carb closed?
Is the carb setup for the secondary to open with throttle and a mechanical lock opening, or has someone toyed with it and made it a mechanical opening mechanism for the secondary.

I should also ask - Weber or the original hitachi carb?

Cheers

Bennie

Benp124
Junior Member
Posts: 5
Joined: Tue Feb 05, 2019 5:30 am

Re: Revs and revs till stalls, what could it be?

Post by Benp124 » Wed Feb 06, 2019 4:49 am

Sounds like the 2wd issue could work by jacking it up, in terms of the carb, I have no idea what it’s supposed to look like, when I got the car the carb was in a hell of a mess, throttle was god knows where and the manual choke disconnected, cable tie instead of a belt drive, this car has had a hard life, I’ll try get a good picture of the carb setup as is and see if it can rectified because as is I’ve done myself just with guesswork, could be missing springs or something


And it’s the original hitachi carb

pitrack_1
Junior Member
Posts: 318
Joined: Wed Mar 02, 2011 1:16 am
Location: ACT

Re: Revs and revs till stalls, what could it be?

Post by pitrack_1 » Thu Feb 07, 2019 12:53 am

I'll just guess but check the throttle closing spring. If it's missing/weak/stretched, then once the car is running the vacuum could pull the throttle open, redlining it. The stall may be another problem, e.g. poor fuel pump supply or carby float/ float bowl / blocked fast jet issue resulting in fuel starvation (redlining may occur off the pump jet if one is fitted). Once the engine dies, the throttle closes normally & enough fuel gets back in the float bowl to repeat the cycle next start up.

One way to check is when the engine races, block the air intake with something solidish that can withstand a vacuum, e.g. a piece of plywood with a bit of foam around the edge to form a seal. Not a piece of paper or rag, that might get sucked in. Engine should die/spin down.

Just a guess.
Patrick
Ex- 2010 Forester Diesel

Benp124
Junior Member
Posts: 5
Joined: Tue Feb 05, 2019 5:30 am

Re: Revs and revs till stalls, what could it be?

Post by Benp124 » Sat Feb 09, 2019 4:21 am

I’ve had a look under the bonnet at the carb, nothing looks out of place apart from a line coming from the carb, it’s connected with a blue valve and the line goes towards the right strut tower, could this be a cause for my issues and what line is this? I would post pictures but I’m still figuring this website out

User avatar
L-Rex
Junior Member
Posts: 54
Joined: Tue Sep 18, 2018 6:03 am
Location: Wollongong, NSW.

Re: Revs and revs till stalls, what could it be?

Post by L-Rex » Sat Feb 09, 2019 4:40 am

Probably the line that goes to the vacuum reservoir for the HVAC controls. This is a required item.
L-Rex

1992 L-Series Wagon, which used to be EA82 auto.

User avatar
El_Freddo
Junior Member
Posts: 11867
Joined: Tue Oct 04, 2005 10:00 am
Location: Benders (aka Bendigo) Vic

Re: Revs and revs till stalls, what could it be?

Post by El_Freddo » Sat Feb 09, 2019 5:04 pm

No vacuum reservoir on the brumby. When you say right hand side you mean when you’re looking at the engine from the front of the car or the actual right hand side of the vehicle?

Only asking as when talking left/right we always refer to the vehicle’s left/right, not the way you’re looking at the vehicle as the orientation changes and it can get confusing.

That blue piece in the vac pipe is normal. There might be a green one too. These won’t be the issue.

Got any pics of the carb or the vac lines you have questions about?

Cheers

Bennie

PS - photos: use a third party hosting site. Then use [img]picaddress and the same bracket code but with / before the img bit.

User avatar
L-Rex
Junior Member
Posts: 54
Joined: Tue Sep 18, 2018 6:03 am
Location: Wollongong, NSW.

Re: Revs and revs till stalls, what could it be?

Post by L-Rex » Sat Feb 09, 2019 5:38 pm

El_Freddo wrote:
Sat Feb 09, 2019 5:04 pm
No vacuum reservoir on the brumby.
Yeah, I should have put my brain in gear... :oops:
L-Rex

1992 L-Series Wagon, which used to be EA82 auto.

Benp124
Junior Member
Posts: 5
Joined: Tue Feb 05, 2019 5:30 am

Re: Revs and revs till stalls, what could it be?

Post by Benp124 » Sun Feb 10, 2019 3:16 am

I’ve taken pictures and a video of my carb setup, wondering what could be wrong?? And sorry I meant as if I was looking at the engine bay but would be the left from inside the car

The pictures+ a video https://imgur.com/gallery/KEcOCxn

I know there appears to be 100 things wrong but I’m looking to fix this issue first then work my way through rebuilding the carb

Benp124
Junior Member
Posts: 5
Joined: Tue Feb 05, 2019 5:30 am

Re: Revs and revs till stalls, what could it be?

Post by Benp124 » Tue Feb 12, 2019 8:52 am

Update so far, got the car running and idling, idle is very very fast with the choke all the way closed, as it warms up by pulling the choke the car slowly spins down the revs but does stay idling, I’ve tried the idle speed screw but it seems like the further out I screw it the louder it gets and screwing it in makes the engine race, how do I know how far it should be in, and I’ve not been able to push my choke all the way in as I’ve got a rad leak that blasts coolant when I get up the temperatures, until that’s fixed I can’t see it run off choke, so my question is how do I know the idle is correct and how many revs is too many? Anyone got a video of what a correct idle would sound like? I’m sure when I eventually put a Weber on it these will be fixed but for now I want a sort of functioning engine, any help is greatly appreciated!

User avatar
L-Rex
Junior Member
Posts: 54
Joined: Tue Sep 18, 2018 6:03 am
Location: Wollongong, NSW.

Re: Revs and revs till stalls, what could it be?

Post by L-Rex » Thu Feb 14, 2019 2:55 am

Get the coolant issue sorted, then start setting up the carb. You want to have it a full operating temp so you can adjust it. It also sounds like you may have an air leak in the pipework or manifold.
L-Rex

1992 L-Series Wagon, which used to be EA82 auto.

User avatar
TOONGA
Junior Member
Posts: 5245
Joined: Sat May 30, 2009 10:15 am
Location: Australind closer to where they divided by zero
Contact:

Re: Revs and revs till stalls, what could it be?

Post by TOONGA » Sat Mar 02, 2019 9:49 am

I'm curious as to how you are getting this engine to run at all

no accelerator pump or pump pusher guide (for want of words to describe the missing part)

Image

it should look like this

Image

It will never idle or run properly without the missing parts.

TOONGA

Post Reply